Author Topic: New router recommendations  (Read 4395 times)

0 Members and 1 Guest are viewing this topic.

Offline stevey

  • Young HAWNESS
  • Score: 13
    • View Profile
New router recommendations
« on: August 29, 2007, 03:18:18 AM »
I finally got broadband! of my own and now I need a good (read: cheap) wireless router that will work with the WII and DS, so any recommendation of what to buy or stay away from would be very helpful.
My Demands and Declarations:
nVidia is CRAP!!!
BOYCOTT Digest mode and LEGEND OF OO!

Your PM box will be spammed with Girl Link porn! NO EXCEPTION!
Wii want WaveBirds

Stevey Duff
NWR HAWTNESS Inspector
NWR Staff All Powerful Satin!

Offline Mashiro

  • Silent Protagonist
  • Score: 1
    • View Profile
RE: New router recommendations
« Reply #1 on: August 29, 2007, 11:12:11 AM »
I have the Linksys Wireless-G Router (Model WRT54GS). I'm not sure how expensive it is now but I got it at best buy for a reasonable price a number of months ago and it works really well so far.

Offline IceCold

  • I love you Vanilla Ice!
  • Score: 1
    • View Profile
RE: New router recommendations
« Reply #2 on: September 11, 2007, 08:53:35 PM »
I have the WRT54G too and I would recommend it. I got it for like $30 CDN after a mail-in rebate from Staples - if you look around I'm sure you can find a good deal  
"I used to sell furniture for a living. The trouble was, it was my own."
---------------------------------------------
"If your parents never had children, chances are you won't either."
----------------------------
"If it weren't for electricity we'd all be watching television by the candlelig

Offline Shift Key

  • MISTER HAPPY-GO-LUCKY
  • Score: 9
    • View Profile
RE:New router recommendations
« Reply #3 on: September 11, 2007, 09:09:37 PM »
Two cans and a piece of string fixes all problems.





Seriously though, just about any router out there these days is Wii-friendly.

I had this strange problem where I would get a disconnect error after every Strikers online series (not match, it worked fine up until that point). Turns out that I had a problem with TCP ports closing too early (which also affected MSN conversations and the like) and required access to the internal configurations of the router to fix it.

But now it all works.